MPLS_LAP

 

الـكــاتب

‎ نزار محمود صقران ‎‎   مهندس كمبيوتر حاصل على  بكلريوس هندسة اتصالات  من ليبيا الحره و كذا عدة شهادات سيسكو ومؤسس ومدير موقع العربي للكمبيوترمهتم بشبكات سيسكو والمايكروسفت والبرمجة بالدت نت لبرمجة برتوكولات  الشبكات والاتصالات وكذا تصميم وتطوير  المواقع  الالكترونية  ويطمح ان يكون المحتوى العربي الافضل وان يعاد للامة الاسلامية والعربية مكانتها العلمية .

MPLS العملي



بالنظر للشبكة بالشكل ادناه سيتبين انها عبارة عن تسعة راوترات ولتفهمها وحلحلتها نقسمها الى ثلاثة اقسام : فالقسم الاول المتمثل في R1,R2,R8,R9 عباره عن روترات CE العميل . اما القسم الثاني المتمثل بالروترات R3,R7 بتكون اجهزة مزود الخدمة على الحافة والتي يطلق عليها:
 PROVIDER Edge -PE    او   Edge LABEL SWITCH ROUTER -ELSR 
اما القسم الثالث المتمثل بالروترات R4,R5,R6 فهي روترات الكور CORE والتي يطلق عليها LSR- LABEL SWITCH ROUTER او  PROVIDER -P.
 


 


نبدا بتطبيق الاعدادات على الشبكة بالخطوات ادناه او التوجه للمصدر
 http://chetanress.blogspot.com.”
ولكي نبدا الاعدادات ناخذ كل قسم من الاقسام الثلاثة نظرا لحالة التشابه في الاعدادات ولتسهيل فهمها: والبداية بتكون من نصيب CUST. EDGE اي CE والمتمثلة بالروترات R1,R2,R8.R9

لتجهيز CE نبدا بالروتر R1 بالخطوات التالية:
1- تخليق واعداد ثلاثة منافذ وهمية LoopBack.
2- اعداد المنفذ F0/0 تم ربطه بالـ PE وتشغيل ospf مع تحديد الكوست له ip ospf cost 50
3- تخليق خط احتياطي Backup link عبر المنفذ F1/0
لربطه بالروتر R8 وتم اعداده وتشغيل OSPF وتحديد له كوست اعلى ip ospf cost 100

وبهذاه الطريقة يتم اعداد بقية الــ CE اي بقية اروترات R2,R8,R9 ولاتوجد اي افكار اخرى.


‎ R1 – Router ! ‎ R2 – Router

interface Loopback1
ip address 10.1.1.1 255.255.255.252
interface Loopback2
ip address 10.2.1.1 255.255.255.255
interface Loopback3
ip address 10.3.1.1 255.255.255.255
interface FastEthernet0/0 description
***** Connected to PE1 Router *****
ip address 10.250.10.1 255.255.255.252
ip ospf cost 50
duplex auto speed auto
interface FastEthernet1/0
description ***** Connected to
R8 – Backup link *****
ip address 172.16.1.1 255.255.255.252
ip ospf cost 100
ip ospf 1 area 0
duplex auto speed auto
router ospf 1
log-adjacency-changes
network 10.1.1.1 0.0.0.0 area 0
network 10.2.1.1 0.0.0.0 area 0
network 10.3.1.1 0.0.0.0 area 0
network 10.250.10.0 0.0.0.3 area 0
‎ interface Loopback1
ip address 20.1.1.1 255.255.255.255
interface Loopback2
ip address 20.2.1.1 255.255.255.255
interface Loopback3
ip address 20.3.1.1 255.255.255.255
interface FastEthernet1/0
description ***** Connected to PE-2 **
ip address 10.250.20.1 255.255.255.252
ip ospf cost 50
duplex auto speed auto
interface FastEthernet1/1
description Connected to R9 – Backup link
ip address 172.16.2.1 255.255.255.252
ip ospf cost 100 ip ospf 2 area 0
duplex auto speed auto
router ospf 2
log-adjacency-changes
network 10.250.20.0 0.0.0.3 area 0
network 20.1.1.1 0.0.0.0 area 0
network 20.2.1.1 0.0.0.0 area 0
network 20.3.1.1 0.0.0.0 area 0
‎ R8 – Router !
‎ R9 – Router

interface Loopback1
ip address 80.1.1.1 255.255.255.255
interface Loopback2
ip address 80.2.1.1 255.255.255.255
interface Loopback3
ip address 80.3.1.1 255.255.255.255
interface FastEthernet0/0
description ***** Connected to
PE-2 *****
ip address 10.250.80.1 255.255.255.252
ip ospf cost 50
duplex auto speed auto interface FastEthernet1/0
Description ***** Connected to R1
— Backup Link *****
ip address 172.16.1.2 255.255.255.252
ip ospf cost 100
ip ospf 1 area 0
duplex auto speed auto!
router ospf 1
log-adjacency-changes
network 10.250.80.0 0.0.0.3 area 0
network 80.1.1.1 0.0.0.0 area 0
network 80.2.1.1 0.0.0.0 area 0
network 80.3.1.1 0.0.0.0 area
‎ interface Loopback1
ip address 90.1.1.1 255.255.255.255
! interface Loopback2
ip address 90.2.1.1 255.255.255.255
! interface Loopback3
ip address 90.3.1.1 255.255.255.255
! !
interface FastEthernet1/0
description ***** Connected to PE-2 *****
ip address 10.250.90.1 255.255.255.252
ip ospf cost 50
duplex auto
speed auto
! interface FastEthernet1/1
description ***** Connected to R2 Backup Link *****
ip address 172.16.2.2 255.255.255.252
ip ospf cost 100
ip ospf 2 area 0
duplex auto
speed auto! !
router ospf 2 log-adjacency-changes
network 10.250.90.0 0.0.0.3 area 0
network 90.1.1.1 0.0.0.0 area 0
network 90.2.1.1 0.0.0.0 area 0
network 90.3.1.1 0.0.0.0 area 0

الان سنتوجة الى اجهزة PE وطبعا المقصود منها R3,R7 ونظرا لمهامها الكبيره فالاعدادا كثيره والقائمة طويلة.. وفيما يلي سنسرد اهم الخطوات او الافكار التي طبقناها في PE للشبكة:
1- عمل مسارات وهمية VRF والفكره الاساسية للــ VRF هو بدل من اظهار المسارات في الروتن تيبل يتم اخذ المسارات المستهدفة ووضعها في مسارات خاصه بها بحيث لاتظهر في الروتن تيبل الاساسي.
2- عمل OSPF sham-link .
3- اتمام الاعدادات للمنافذ.
4- عمل قنوات TUNNEL تربط مابين راوترين PE اي مابين R3 و R7
5-اعداد OSPF.
6- اعداد BGP .
7- وطبعا تشغيل MPLS .
8- تشغيل TE والذي بيعني Traffic-Engineering وهو تقنية مهمة للتحكم بالترفك ولنا فيه وقفات .
ملاحظه: بالنسبة للخطوات اعلاه سوف نعمل باذن الله مثال عملي مع الشرح لكل الية او تقنية فلا يقلق احد .
‎ R3 – Router !
‎ R7 – Router

ip vrf CUST_A
rd 65:1
route-target export 65:1
route-target import 65:1
ip vrf CUST_B rd 65:2
route-target export 65:2
route-target import 65:2
mpls traffic-eng tunnels
interface Loopback10
ip address 3.3.3.3 255.255.255.255
interface Loopback100
description Used For OSPF Sham-Link
ip vrf forwarding CUST_A
ip address 100.100.100.100 255.255.255.255
interface Loopback200
description Used For OSPF Sham-Link
ip vrf forwarding CUST_B
ip address 50.50.50.50 255.255.255.255
interface Tunnel10
ip unnumbered Loopback10
tunnel destination 7.7.7.7
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng
autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 2000
tunnel mpls traffic-eng path-option 1
dynamic no routing dynamic
interface Tunnel20
ip unnumbered Loopback10
tunnel destination 7.7.7.7
tunnel mode mpls traffic-eng
tunnel mpls
traffic-eng autoroute announce
tunnel mpls
traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 2000
tunnel mpls traffic-eng path-option 1
explicit name R3-R4-R5-R7
no routing dynamic
interface FastEthernet0/0
description * Connected to R1
ip vrf forwarding CUST_A
ip address 10.250.10.2 255.255.255.252
duplex auto speed auto
interface FastEthernet1/0
description ***** Connected to R2
ip vrf forwarding CUST_B
ip address 10.250.20.2 255.255.255.252
duplex auto speed auto
interface Serial3/0
description **Connected to P2_CORE *
bandwidth 2000
ip address 15.1.1.1 255.255.255.252
encapsulation ppp
mpls label protocol ldp mpls
ip mpls traffic-eng
tunnels serial restart-delay 0
ip rsvp bandwidth 2000 2000
interface Serial3/1
description *****Connected to P1_CORE
bandwidth 2000
ip address 15.3.1.1 255.255.255.252
encapsulation ppp
mpls label protocol
ldp mpls
ip mpls
traffic-eng
tunnels serial restart-delay 0
ip rsvp bandwidth 2000 2000 ! !
router ospf 1
vrf CUST_A log-adjacency-changes
area 0 sham-link 100.100.100.100 200.200.200.200
redistribute bgp 65000
subnets network 10.250.10.0 0.0.0.3 area 0
router ospf 2
vrf CUST_B
log-adjacency-changes
area 0 sham-link 50.50.50.50 60.60.60.60
redistribute bgp 65000
subnets network 10.250.20.0 0.0.0.3 area 0
router ospf 10
mpls traffic-eng
router-id Loopback10
mpls traffic-eng
area 0 router-id 3.3.3.3
log-adjacency-changes
no auto-cost
network 3.3.3.3 0.0.0.0 area 0
network 15.1.1.0 0.0.0.3
area 0 network 15.3.1.0 0.0.0.3 area 0 !
router bgp 65000
bgp log-neighbor-changes
neighbor 7.7.7.7 remote-as 65000
neighbor 7.7.7.7 update-source
Loopback10 !
address-family ipv4
neighbor 7.7.7.7
activate no auto-summary
no synchronization
exit-address-family !
address-family vpnv4
neighbor 7.7.7.7 activate
neighbor 7.7.7.7
send-community extended
exit-address-family
address-family ipv4
vrf CUST_B
redistribute connected redistribute ospf 2
vrf CUST_B
no synchronization
exit-address-family !
address-family
ipv4 vrf CUST_A
redistribute connected redistribute ospf 1
vrf CUST_A
no synchronization
exit-address-family ! !
no ip http server
no ip http secure-server ! !
ip explicit-path name R3-R4-R5-R7
enable next-address 15.1.1.2
next-address 15.2.1.2
next-address 15.5.1.2
next-address 7.7.7.7 !
mpls ldp
router-id Loopback10
‎ ip vrf CUST_A
rd 65:1
route-target export 65:1
route-target import 65:1
ip vrf CUST_B rd 65:2
route-target export 65:2
route-target import 65:2
mpls traffic-eng tunnels
interface Loopback10
ip address 7.7.7.7 255.255.255.255
interface Loopback100
Description ***** Used For OSPF Sham-Link *****
ip vrf forwarding CUST_A
ip address 200.200.200.200 255.255.255.255
interface Loopback200
Description ***** Used For OSPF Sham-Link *****
ip vrf forwarding CUST_B
ip address 60.60.60.60 255.255.255.255 ! !
interface Tunnel10
ip unnumbered Loopback10
tunnel destination 3.3.3.3
tunnel mode mpls
traffic-eng tunnel
mpls traffic-eng
autoroute announce
tunnel mpls
traffic-eng priority 1 1
tunnel mpls
traffic-eng bandwidth 2000
tunnel mpls
traffic-eng path-option 1 dynamic
no routing dynamic !
interface Tunnel20
ip unnumbered Loopback10
tunnel destination 3.3.3.3
tunnel mode mpls
traffic-eng tunnel mpls
traffic-eng autoroute announce
tunnel mpls
traffic-eng priority 3 3
tunnel mpls
traffic-eng bandwidth 2000
tunnel mpls traffic-eng
path-option 1 explicit name R7-R5-R4-R3
no routing dynamic !
interface FastEthernet0/0
description ***** Connected to R8 *****
ip vrf forwarding CUST_A
ip address 10.250.80.2 255.255.255.252
duplex auto speed auto ! !
interface FastEthernet1/0
description ***** Connected to R9 *****
ip vrf forwarding CUST_B
ip address 10.250.90.2 255.255.255.252
duplex auto speed auto
interface Serial3/0
description Connected to P1_CORE
bandwidth 2000
ip address 15.4.1.2 255.255.255.252
encapsulation ppp
mpls label protocol ldp
mpls ip mpls traffic-eng
tunnels serial restart-delay 0
ip rsvp bandwidth 2000 2000 ! !
interface Serial3/2
description Connected to P3_CORE
bandwidth 2000
ip address 15.5.1.2 255.255.255.252
encapsulation ppp
mpls label protocol ldp
mpls ip mpls traffic-eng
tunnels serial restart-delay 0
ip rsvp bandwidth 2000 2000
router ospf 1
vrf CUST_A log-adjacency-changes area 0
sham-link 200.200.200.200 100.100.100.100
redistribute bgp 65000 subnets
network 10.250.80.0 0.0.0.3 area 0 !
router ospf 2
vrf CUST_B
log-adjacency-changes area 0
sham-link 60.60.60.60 50.50.50.50
redistribute bgp 65000 subnets
network 10.250.90.0 0.0.0.3 area 0 ! !
router ospf 10
mpls traffic-eng router-id
Loopback10
mpls traffic-eng area 0
log-adjacency-changes
network 7.7.7.7 0.0.0.0 area 0
network 15.4.1.0 0.0.0.3 area 0
network 15.5.1.0 0.0.0.3 area 0 !
router bgp 65000
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 65000
neighbor 3.3.3.3 update-source Loopback10 !
address-family ipv4
neighbor 3.3.3.3 activate
no auto-summary
no synchronization
exit-address-family
! address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community extended
exit-address-family !
address-family ipv4
vrf CUST_B
redistribute connected redistribute ospf 2
vrf CUST_B
no synchronization
exit-address-family !
address-family ipv4
vrf CUST_A redistribute connected redistribute ospf 1
vrf CUST_A
no synchronization
exit-address-family ! !
ip explicit-path name R7-R5-R4-R3 enable
next-address 15.5.1.1
next-address 15.2.1.1
next-address 15.1.1.1
next-address 3.3.3.3 !
mpls ldp
router-id Loopback10

وفي القسم الاخير وهو اجهزة
P- PROVIDER او LSR- LABEL SWICH ROUTER
وفيها بنهتم بــــ
:
1- اعداد MPLS
2- اعداد TE
3- اعداد OSPF
4- اعداد rsvp
‎ R4 – Router ! ‎ R5 – Router ! ‎ R6 – Router !

mpls traffic-eng tunnels
interface Loopback10
ip address 4.4.4.4 255.255.255.255
interface Serial3/0
description Connected to PE1_ROUTER
bandwidth 2000
ip address 15.1.1.2 255.255.255.252
encapsulation ppp
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
ip rsvp bandwidth 2000 2000
interface Serial3/1
description Connected to P3_CORE
bandwidth 2000
ip address 15.2.1.1 255.255.255.252
encapsulation ppp
mpls label protocol ldp mpls
ip mpls traffic-eng tunnels
serial restart-delay 0
ip rsvp bandwidth 2000 2000
router ospf 10
mpls traffic-eng router-id Loopback10
mpls traffic-eng area 0
router-id 4.4.4.4
log-adjacency-changes
no auto-cost
network 4.4.4.4 0.0.0.0 area 0
network 15.1.1.0 0.0.0.3 area 0
network 15.2.1.0 0.0.0.3 area 0
mpls ldp router-id Loopback10

mpls traffic-eng tunnels
interface Loopback10
ip address 5.5.5.5 255.255.255.255
interface Serial3/1
description Connected to P2_CORE
bandwidth 2000
ip address 15.2.1.2 255.255.255.252
encapsulation ppp
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
ip rsvp bandwidth 2000 2000
interface Serial3/2
description Connected to PE2_ROUTER
bandwidth 2000
ip address 15.5.1.1 255.255.255.252
encapsulation ppp
mpls label protocol ldp
mpls ip mpls traffic-eng tunnels
serial restart-delay 0
ip rsvp
bandwidth 2000 2000
router ospf 10
mpls traffic-eng area 0
router-id 5.5.5.5
log-adjacency-changes
no auto-cost
network 5.5.5.5 0.0.0.0 area 0
network 15.2.1.0 0.0.0.3 area 0
network 15.5.1.0 0.0.0.3 area 0
mpls ldp
router-id Loopback10



mpls traffic-eng tunnels
interface Loopback10
ip address 6.6.6.6 255.255.255.255
interface Serial3/0
description Connected to PE2_ROUTER *
bandwidth 2000
ip address 15.4.1.1 255.255.255.252
encapsulation ppp
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
ip rsvp bandwidth 2000 2000
interface Serial3/1
description Connected to PE1_ROUETR
bandwidth 2000
ip address 15.3.1.2 255.255.255.252
encapsulation ppp
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
ip rsvp bandwidth 2000 2000
router ospf 10
mpls traffic-eng router-id Loopback10
mpls traffic-eng area 0
router-id 6.6.6.6
log-adjacency-changes
no auto-cost
network 6.6.6.6 0.0.0.0 area 0
network 15.3.1.0 0.0.0.3 area 0
network 15.4.1.0 0.0.0.3 area 0
mpls ldp router-id Loopback10



والان نتحقق من الشبكة ونستكشف بعض مافيها: اولا نستعرض الروتن تيبل:

‎ R1#show ip route

 

 ‎ R8#sh ip route

R1#show ip route
200.200.200.0/32 is subnetted, 1 subnets
O E2 200.200.200.200 [110/1] via 10.250.10.2, 00:27:49, F 0/0
100.0.0.0/32 is subnetted, 1 subnets
O E2 100.100.100.100 [110/1] via 10.250.10.2, 00:27:49, F 0/0
80.0.0.0/32 is subnetted, 3 subnets
O 80.1.1.1 [110/53] via 10.250.10.2, 00:27:49, F 0/0
O 80.2.1.1 [110/53] via 10.250.10.2, 00:27:49, F 0/0
O 80.3.1.1 [110/53] via 10.250.10.2, 00:27:49, F 0/0
172.16.0.0/30 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, F 1/0
10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C 10.2.1.1/32 is directly connected, Loopback2
C 10.3.1.1/32 is directly connected, Loopback3
C 10.1.1.0/30 is directly connected, Loopback1
O 10.250.80.0/30 [110/52] via 10.250.10.2, 00:27:54, F 0/0
C 10.250.10.0/30 is directly connected, F 0/0

22



R8#sh ip route
200.200.200.0/32 is subnetted, 1 subnets
O E2 200.200.200.200 [110/1] via 10.250.80.2, 00:44:02, F 0/0
100.0.0.0/32 is subnetted, 1 subnets
O E2 100.100.100.100 [110/1] via 10.250.80.2, 00:44:02, F 0/0
80.0.0.0/32 is subnetted, 3 subnets
C 80.1.1.1 is directly connected, Loopback1
C 80.2.1.1 is directly connected, Loopback2
C 80.3.1.1 is directly connected, Loopback3
172.16.0.0/30 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, F 1/0
10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O 10.2.1.1/32 [110/53] via 10.250.80.2, 00:44:02, F 0/0
O 10.3.1.1/32 [110/53] via 10.250.80.2, 00:44:02, F 0/0
O 10.1.1.1/32 [110/53] via 10.250.80.2, 00:44:07, F 0/0
C 10.250.80.0/30 is directly connected, F 0/0
O 10.250.10.0/30 [110/52] via 10.250.80.2, 00:44:07, F 0/0
R8# R8#

‎ CISCO
CISCO
R2#show ip route
50.0.0.0/32 is subnetted, 1 subnets
O E2 50.50.50.50 [110/1] via 10.250.20.2, 00:44:22,
F 1/0 20.0.0.0/32 is subnetted, 3 subnets
C 20.1.1.1 is directly connected, Loopback1
C 20.2.1.1 is directly connected, Loopback2
C 20.3.1.1 is directly connected, Loopback3
.16.0.0/30 is subnetted, 1 subnets
C 172.16.2.0 is directly connected,
F 1/1 10.0.0.0/30 is subnetted, 2 subnets
O 10.250.90.0 [110/52] via 10.250.20.2, 00:44:22, F 1/0
C 10.250.20.0 is directly connected,
F 1/0 90.0.0.0/32 is subnetted, 3 subnets
O 90.2.1.1 [110/53] via 10.250.20.2, 00:44:22, F 1/0
O 90.3.1.1 [110/53] via 10.250.20.2, 00:44:24, F 1/0
O 90.1.1.1 [110/53] via 10.250.20.2, 00:44:24,
F 1/0 60.0.0.0/32 is subnetted, 1 subnets
O E2 60.60.60.60 [110/1] via 10.250.20.2, 00:44:25,
F 1/0
R2#

22


R9#show ip route
50.0.0.0/32 is subnetted, 1 subnets
O E2 50.50.50.50 [110/1] via 10.250.90.2, 00:46:50,
F 1/0 20.0.0.0/32 is subnetted, 3 subnets
O 20.1.1.1 [110/53] via 10.250.90.2, 00:46:50,F 1/0
O 20.2.1.1 [110/53] via 10.250.90.2, 00:46:50, F 1/0
O 20.3.1.1 [110/53] via 10.250.90.2, 00:46:50, F 1/0
172.16.0.0/30 is subnetted, 1 subnets
C 172.16.2.0 is directly connected, F 1/1
10.0.0.0/30 is subnetted, 2 subnets
C 10.250.90.0 is directly connected, F 1/0
O 10.250.20.0 [110/52] via 10.250.90.2, 00:46:50, F 1/0
90.0.0.0/32 is subnetted, 3 subnets
C 90.2.1.1 is directly connected, Loopback2
C 90.3.1.1 is directly connected, Loopback3
C 90.1.1.1 is directly connected, Loopback1
60.0.0.0/32 is subnetted, 1 subnets
O E2 60.60.60.60 [110/1] via 10.250.90.2, 00:46:52, F 1/0
R9#

‎ CISCO ‎ CISCO

R3#sh mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
RSVP Process: running
Forwarding: enabled
Periodic reoptimization: every 3600 seconds,
next in 2576 seconds Periodic auto-bw collection:
disabled
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PROT
R3_t10 7.7.7.7 – Se3/1 up/up
R3_t20 7.7.7.7 – unknown up/down
R7_t10 3.3.3.3 Se3/1 – up/up Displayed 2 (of 2) heads, 0 (of 0)
midpoints, 1 (of 1) tails
R3#

22



R7#sh mpls traffic-eng tunnels brief
R7#sh mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
RSVP Process: running Forwarding: enabled
Periodic reoptimization: every 3600 seconds,
next in 3455 seconds Periodic auto-bw collection: disabled
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PROT
R7_t10 3.3.3.3 – Se3/0 up/up
R7_t20 3.3.3.3 – unknown up/down
R3_t10 7.7.7.7 Se3/0 up/up
Displayed 2 (of 2) heads, 0 (of 0) midpoints, 1 (of 1) tails R7#

‎ CISCO
 
3 CISCO

R3#sh ip ospf sham-links
R3#sh ip ospf sham-links
Sham Link OSPF_SL1 to address 60.60.60.60 is up
Area 0 source address 50.50.50.50
Run as demand circuit
DoNotAge LSA allowed. Cost of using 1 State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40,
Hello due in 00:00:04 Adjacency State FULL (Hello suppressed)
Index 2/2, retransmission queue length 0, number of retransmission 1
First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
Last retransmission scan length is 1, maximum is 1
Last retransmission scan time is 0 msec, maximum is 0 msec
Sham Link OSPF_SL0 to address 200.200.200.200 is up
Area 0 source address 100.100.100.100
Run as demand circuit
DoNotAge LSA allowed. Cost of using 1 State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40,
Hello due in 00:00:04
Adjacency State FULL (Hello suppressed)
Index 2/2, retransmission queue length 0, number of retransmission 1
First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
Last retransmission scan length is 1, maximum is 1
Last retransmission scan time is 0 msec, maximum is 0 msec R3#

22



R7#sh ip ospf sham-links
R7#sh ip ospf sham-links
Sham Link OSPF_SL1 to address 50.50.50.50 is up
Area 0 source address 60.60.60.60
Run as demand circuit
DoNotAge LSA allowed. Cost of using 1 State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40,
Hello due in 00:00:04 Adjacency State FULL (Hello suppressed)
Index 1/1, retransmission queue length 0, number of retransmission 1
First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
Last retransmission scan length is 1, maximum is 1
Last retransmission scan time is 0 msec, maximum is 0 msec
Sham Link OSPF_SL0 to address 100.100.100.100 is up
Area 0 source address 200.200.200.200
Run as demand circuit
DoNotAge LSA allowed. Cost of using 1 State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40,
Hello due in 00:00:04
Adjacency State FULL (Hello suppressed)
Index 1/1, retransmission queue length 0, number of retransmission 1
First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0) Last retransmission scan length is 1, maximum is 1
Last retransmission scan time is 0 msec, maximum is 0 msec

CISCO

R7#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
5.5.5.5 0 FULL/ – 00:00:32 15.5.1.1 Serial3/2
6.6.6.6 0 FULL/ – 00:00:33 15.4.1.1 Serial3/0
90.3.1.1 1 FULL/BDR 00:00:33
10.250.90.1 FastEthernet1/ 0
50.50.50.50 0 FULL/ – – 50.50.50.50 OSPF_SL1
80.3.1.1 1 FULL/BDR 00:00:36 10.250.80.1 FastEthernet0/ 0
100.100.100.100 0 FULL/ – – 100.100.100.100 OSPF_SL0
R7# >br>

لمعرفة حركة الليبلات نستعرضها جداول 3 و 4 و5

CISCO CISCO CISCO

R3#sh mpl ip bi lo
3.3.3.3/32 in label: imp-null
4.4.4.4/32 in label: 29
5.5.5.5/32 in label: 31
6.6.6.6/32 in label: 33
7.7.7.7/32 in label: 36
15.1.1.0/30 in label: imp-null
15.1.1.2/32 in label: 28
15.2.1.0/30 in label: 30
15.3.1.0/30 in label: imp-null
15.3.1.2/32 in label: 32
15.4.1.0/30 in label: 34
15.5.1.0/30 in label: 35
R3#
R3#

R4#sh mpls ip binding local
3.3.3.3/32 in label: 17 7
4.4.4.4/32 in label: imp-null
5.5.5.5/32 in label: 19
6.6.6.6/32 in label: 21
7.7.7.7/32 in label: 24
15.1.1.0/30 in label: imp-null >br> 15.1.1.1/32 in label: 16
15.2.1.0/30 in label: imp-null
15.2.1.2/32 in label: 18
15.3.1.0/30 in label: 20
15.4.1.0/30 in label: 22
15.5.1.0/30 in label: 23
R4#

R5#sh mpls ip binding local
3.3.3.3/32 in label: 17
4.4.4.4/32 in label: 18
5.5.5.5/32 in la bel: imp-null
6.6.6.6/32 in label: 21
7.7.7.7/32 in label: 24
15.1.1.0/30 in label: 19
15.2.1.0/30 in label: imp-null
15.2.1.1/32 in label: 16
15.3.1.0/30 in label: 20
15.4.1.0/30 in label: 22
15.5.1.0/30 in label: imp-null
15.5.1.2/32 in label: 23
R5#
R5#

جداول 6و7

CISCO CISCO

R6#sh mpls ip binding local
3.3.3.3/32 in label: 17
4.4.4.4/32 in label: 18
5.5.5.5/32 in label: 19
6.6.6.6/32 in label: imp-null
7.7.7.7/32 in label: 26
15.1.1.0/30 in label: 20
15.2.1.0/30 in label: 21
15.3.1.0/30 in label: imp-null
15.3.1.1/32 in label: 16
15.4.1.0/30 in label: imp-null
15.4.1.2/32 in label: 22
15.5.1.0/30 in label: 23
R6#
R6#

22



R7#sh mpl ip bi lo
3.3.3.3/32 in label: 18
4.4.4.4/32 in label: 19
5.5.5.5/32 in label: 20
6.6.6.6/32 in label: 21
7.7.7.7/32 in label: imp-null
15.1.1.0/30 in label: 22
15.2.1.0/30 in label: 23
15.3.1.0/30 in label: 24
15.4.1.0/30 in label: imp-null
15.4.1.1/32 in label: 16
15.5.1.0/30 in label: imp-null
15.5.1.1/32 in label: 17
R7#

السطر الاول في اجهزة CE والمتمثلة في الشبكة هي R1,R2,R8,R9 لسنا بحاجة تشغيل MPLS ولاثبات ذلك نستعرض الــ binding فنجد ان LIB غير مفعل :
R1#sh mpls ip binding
local LIB not enabled
R2#sh mpls ip binding local LIB not enabled

 
R8#sh mpls ip binding
local LIB not enabled


اترك رد

إملأ الحقول أدناه بالمعلومات المناسبة أو إضغط على إحدى الأيقونات لتسجيل الدخول:

WordPress.com Logo

أنت تعلق بإستخدام حساب WordPress.com. تسجيل خروج   / تغيير )

صورة تويتر

أنت تعلق بإستخدام حساب Twitter. تسجيل خروج   / تغيير )

Facebook photo

أنت تعلق بإستخدام حساب Facebook. تسجيل خروج   / تغيير )

Google+ photo

أنت تعلق بإستخدام حساب Google+. تسجيل خروج   / تغيير )

Connecting to %s